Le forum a migré vers l'adresse suivante:

Forum

Masquer ce message

Simple-Duino Index du Forum



Problème pour créer un pwm à 20kHz avec ARduino Mega 2560


 
Poster un nouveau sujet   Répondre au sujet    Simple-Duino Index du Forum -> Arduino & Électronique -> Questions
Sujet précédent :: Sujet suivant  
Auteur Message
Franck57000
Débutant

Hors ligne

Inscrit le: 23 Juil 2014
Messages: 1
Masculin
Niveau d'éléctronique: Intermédiaire

MessagePosté le: Mer 23 Juil - 09:16 (2014)    Sujet du message: Problème pour créer un pwm à 20kHz avec ARduino Mega 2560 Répondre en citant

PublicitéSupprimer les publicités ?
Bonjour,

je m'occupe de créer des programmes pour tester des moteurs. j'ai besoin de créer une rampe avec un pwm à 20kHZ sur les pin 9 et 10.
Est ce que cela est possible en paramétrant les timer de l'atmega?
Je sais qu'il existe des presaclers :
TIMER 2 (Pin 9, 10)
Value Divisor Frequency
0×01 1          31.374 KHz
0×02 8          3.921 KHz
0×03 32        980.3 Hz
0×04 64        490.1 Hz // default
0×05 128      245 hz
0×06 256      122.5 hz
0×07 1024     30.63 hz
Code: TCCR2B = (TCCR2B & 0xF8) | value ;

Mais j'ai besoin de mettre ce timer à 20khz.

Quelqu'un pour m'aiguiller?

Merci de vos réponses
Revenir en haut
Contenu Sponsorisé






MessagePosté le: Aujourd’hui à 00:34 (2017)    Sujet du message: Problème pour créer un pwm à 20kHz avec ARduino Mega 2560

Revenir en haut
Montrer les messages depuis:   
Poster un nouveau sujet   Répondre au sujet    Simple-Duino Index du Forum -> Arduino & Électronique -> Questions Toutes les heures sont au format GMT + 1 Heure
Page 1 sur 1

 
Sauter vers:  

Index | creer un forum | Forum gratuit d’entraide | Annuaire des forums gratuits | Signaler une violation | Conditions générales d'utilisation
Powered by phpBB
Propulsé par Simple-Duino